re = /(?(DEFINE)(?<label>([[:alpha:]]([[:alnum:]-]{0,61}[[:alnum:]])?)|\*))(?=^.{1,255}$)(?:^(?P<name>(?P>label))\.(?P<zone>(?:(?P>label)\.?)*)$)/m
str = 'google.com
mail.google.com
test-.google.com
*.google.com
google.com.
101.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end