using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)(?<label>([[:alpha:]]([[:alnum:]-]{0,61}[[:alnum:]])?)|\*))(?=^.{1,255}$)(?:^(?P<name>(?P>label))\.(?P<zone>(?:(?P>label)\.?)*)$)";
string input = @"google.com
mail.google.com
test-.google.com
*.google.com
google.com.
101.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}