const regex = /(?(DEFINE)(?<label>([[:alpha:]]([[:alnum:]-]{0,61}[[:alnum:]])?)|\*))(?=^.{1,255}$)(?:^(?P<name>(?P>label))\.(?P<zone>(?:(?P>label)\.?)*)$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?<label>([[:alpha:]]([[:alnum:]-]{0,61}[[:alnum:]])?)|\\*))(?=^.{1,255}$)(?:^(?P<name>(?P>label))\\.(?P<zone>(?:(?P>label)\\.?)*)$)', 'gm')
const str = `google.com
mail.google.com
test-.google.com
*.google.com
google.com.
101.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}