$re = '/(?(DEFINE)(?<label>([[:alpha:]]([[:alnum:]-]{0,61}[[:alnum:]])?)|\*))(?=^.{1,255}$)(?:^(?P<name>(?P>label))\.(?P<zone>(?:(?P>label)\.?)*)$)/m';
$str = 'google.com
mail.google.com
test-.google.com
*.google.com
google.com.
101.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);