import Foundation
let pattern = #":(?!:|\s)([^\s|\/]{1,}?)(?=:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #": :smile:http://baidu.com:9090 :smile1:表情:测试1 :smile: :tv_可爱: :smile: :::::smile:: :tv_doge: ::::tv_doge:: :::tv_doge: : :::: :tv_doge: :::tv_doge::smile:smile:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)