re = /:(?!:|\s)([^\s|\/]{1,}?)(?=:)/m
str = ': :smile:http://baidu.com:9090 :smile1:表情:测试1 :smile: :tv_可爱: :smile: :::::smile:: :tv_doge: ::::tv_doge:: :::tv_doge: : :::: :tv_doge: :::tv_doge::smile:smile:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end