#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):(?!:|\s)([^\s|\/]{1,}?)(?=:)"
Local $sString = ": :smile:http://baidu.com:9090 :smile1:表情:测试1 :smile: :tv_可爱: :smile: :::::smile:: :tv_doge: ::::tv_doge:: :::tv_doge: : :::: :tv_doge: :::tv_doge::smile:smile:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")