$re = '/:(?!:|\s)([^\s|\/]{1,}?)(?=:)/m';
$str = ': :smile:http://baidu.com:9090 :smile1:表情:测试1 :smile: :tv_可爱: :smile: :::::smile:: :tv_doge: ::::tv_doge:: :::tv_doge: : :::: :tv_doge: :::tv_doge::smile:smile:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);