use strict;
my $str = 'StNr Laptime Lap Tageszeit
# 665 -02:04.137 6 10:52
# 665 -01:47.625 5 10:50
# 665 -01:49.546 4 10:48
# 665 -01:57.014 3 10:47
# 665 -01:51.407 2 10:45
# 665 -00:00.000 1 10:43
';
my $regex = qr/^#\s(\d+)\s+-?(\d{2}):(\d{2})\.(\d{3})\s(\d+)\s(\d{2}:\d{2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}