const regex = /^#\s(\d+)\s+-?(\d{2}):(\d{2})\.(\d{3})\s(\d+)\s(\d{2}:\d{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#\\s(\\d+)\\s+-?(\\d{2}):(\\d{2})\\.(\\d{3})\\s(\\d+)\\s(\\d{2}:\\d{2})$', 'gm')
const str = `StNr Laptime Lap Tageszeit
# 665 -02:04.137 6 10:52
# 665 -01:47.625 5 10:50
# 665 -01:49.546 4 10:48
# 665 -01:57.014 3 10:47
# 665 -01:51.407 2 10:45
# 665 -00:00.000 1 10:43
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}