import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#\\s(\\d+)\\s+-?(\\d{2}):(\\d{2})\\.(\\d{3})\\s(\\d+)\\s(\\d{2}:\\d{2})$";
final String string = "StNr Laptime Lap Tageszeit\n"
+ "# 665 -02:04.137 6 10:52\n"
+ "# 665 -01:47.625 5 10:50\n"
+ "# 665 -01:49.546 4 10:48\n"
+ "# 665 -01:57.014 3 10:47\n"
+ "# 665 -01:51.407 2 10:45\n"
+ "# 665 -00:00.000 1 10:43\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}