import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\s,-]+(?:(bis|ter|qua)[\s,-]+)?([\w]+[\-\w]*)[\s,]+([-\w].+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
51 bis rue du 26eme régiment d'infanterie
51 ter rue du 26eme régiment d'infanterie
51,bis,rue du 26eme régiment d'infanterie
51 rue du 26eme régiment d'infanterie
51 rue d'Alençon et son apostrophe
51 rue ,du 26eme régiment d'infanterie avec une virgule qui traine
51 bis contre-allée du tiret dans le type de voie
51 rue équateur avec accent en premier caractère de nom de voie
51- rue du tiret inutile après le chiffre
10-12 rue de l'intervalle de numéros de rue
10-12-14-18 rue de l'intervalle beaucoup trop long
51 bis rue -de ' ; la - ,po-nctuation mise n'importe où
51 bis - rue - du 26eme régiment d'infanterie
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)