// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?miu)^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\s,-]+(?:(bis|ter|qua)[\s,-]+)?([\w]+[\-\w]*)[\s,]+([-\w].+)$").unwrap();
let string = "51 bis rue du 26eme régiment d'infanterie
51 ter rue du 26eme régiment d'infanterie
51,bis,rue du 26eme régiment d'infanterie
51 rue du 26eme régiment d'infanterie
51 rue d'Alençon et son apostrophe
51 rue ,du 26eme régiment d'infanterie avec une virgule qui traine
51 bis contre-allée du tiret dans le type de voie
51 rue équateur avec accent en premier caractère de nom de voie
51- rue du tiret inutile après le chiffre
10-12 rue de l'intervalle de numéros de rue
10-12-14-18 rue de l'intervalle beaucoup trop long
51 bis rue -de ' ; la - ,po-nctuation mise n'importe où
51 bis - rue - du 26eme régiment d'infanterie";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}