import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\\s,-]+(?:(bis|ter|qua)[\\s,-]+)?([\\w]+[\\-\\w]*)[\\s,]+([-\\w].+)$";
final String string = "51 bis rue du 26eme régiment d'infanterie\n"
+ "51 ter rue du 26eme régiment d'infanterie\n"
+ "51,bis,rue du 26eme régiment d'infanterie\n"
+ "51 rue du 26eme régiment d'infanterie\n"
+ "51 rue d'Alençon et son apostrophe\n"
+ "51 rue ,du 26eme régiment d'infanterie avec une virgule qui traine\n"
+ "51 bis contre-allée du tiret dans le type de voie\n"
+ "51 rue équateur avec accent en premier caractère de nom de voie\n"
+ "51- rue du tiret inutile après le chiffre\n"
+ "10-12 rue de l'intervalle de numéros de rue\n"
+ "10-12-14-18 rue de l'intervalle beaucoup trop long\n"
+ "51 bis rue -de ' ; la - ,po-nctuation mise n'importe où\n"
+ "51 bis - rue - du 26eme régiment d'infanterie";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}