use strict;
my $str = '51 bis rue du 26eme régiment d\'infanterie
51 ter rue du 26eme régiment d\'infanterie
51,bis,rue du 26eme régiment d\'infanterie
51 rue du 26eme régiment d\'infanterie
51 rue d\'Alençon et son apostrophe
51 rue ,du 26eme régiment d\'infanterie avec une virgule qui traine
51 bis contre-allée du tiret dans le type de voie
51 rue équateur avec accent en premier caractère de nom de voie
51- rue du tiret inutile après le chiffre
10-12 rue de l\'intervalle de numéros de rue
10-12-14-18 rue de l\'intervalle beaucoup trop long
51 bis rue -de \' ; la - ,po-nctuation mise n\'importe où
51 bis - rue - du 26eme régiment d\'infanterie';
my $regex = qr/^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\s,-]+(?:(bis|ter|qua)[\s,-]+)?([\w]+[\-\w]*)[\s,]+([-\w].+)$/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}