$re = '/\Dshared\Dsections\D\d{3,5}[?](program_id|nav_info=&program_id)=6/';
$str = 'Past Strings:
\\Dshared\\Dsections\\D\\d{3,5}[?]nav_info=&{0,1}program_id=6
Pass:
/shared/sections/6032?nav_info=&program_id=6
/shared/sections/6027?program_id=6
/shared/sections/8990?program_id=6
/shared/sections/6115?nav_info=&program_id=6
/shared/sections/7318?program_id=6
/shared/sections/8996?program_id=6
/shared/sections/6324?nav_info=&program_id=6
/shared/sections/6332?program_id=6
/shared/sections/6333?program_id=6
/shared/sections/6334?program_id=6
Fail:
/shared/programs/6/lessons/1126/slide_shows
/shared/programs/6/lessons/964/slide_shows
/shared/programs/6/lessons/944/slide_shows
/shared/programs/6/lessons/963/slide_shows
/shared/programs/6/lessons/970/slide_shows
/shared/sections/7352?nav_info=&program_id=15
/shared/sections/8991?program_id=15
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);