#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\Dshared\Dsections\D\d{3,5}[?](program_id|nav_info=&program_id)=6"
Local $sString = "Past Strings: " & @CRLF & _
"\Dshared\Dsections\D\d{3,5}[?]nav_info=&{0,1}program_id=6" & @CRLF & _
"" & @CRLF & _
"Pass:" & @CRLF & _
"/shared/sections/6032?nav_info=&program_id=6" & @CRLF & _
"/shared/sections/6027?program_id=6" & @CRLF & _
"/shared/sections/8990?program_id=6" & @CRLF & _
"/shared/sections/6115?nav_info=&program_id=6" & @CRLF & _
"/shared/sections/7318?program_id=6" & @CRLF & _
"/shared/sections/8996?program_id=6" & @CRLF & _
"/shared/sections/6324?nav_info=&program_id=6" & @CRLF & _
"/shared/sections/6332?program_id=6" & @CRLF & _
"/shared/sections/6333?program_id=6" & @CRLF & _
"/shared/sections/6334?program_id=6" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Fail:" & @CRLF & _
"/shared/programs/6/lessons/1126/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/964/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/944/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/963/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/970/slide_shows" & @CRLF & _
"/shared/sections/7352?nav_info=&program_id=15" & @CRLF & _
"/shared/sections/8991?program_id=15" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")