import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\Dshared\\Dsections\\D\\d{3,5}[?](program_id|nav_info=&program_id)=6";
final String string = "Past Strings: \n"
+ "\\Dshared\\Dsections\\D\\d{3,5}[?]nav_info=&{0,1}program_id=6\n\n"
+ "Pass:\n"
+ "/shared/sections/6032?nav_info=&program_id=6\n"
+ "/shared/sections/6027?program_id=6\n"
+ "/shared/sections/8990?program_id=6\n"
+ "/shared/sections/6115?nav_info=&program_id=6\n"
+ "/shared/sections/7318?program_id=6\n"
+ "/shared/sections/8996?program_id=6\n"
+ "/shared/sections/6324?nav_info=&program_id=6\n"
+ "/shared/sections/6332?program_id=6\n"
+ "/shared/sections/6333?program_id=6\n"
+ "/shared/sections/6334?program_id=6\n\n\n"
+ "Fail:\n"
+ "/shared/programs/6/lessons/1126/slide_shows\n"
+ "/shared/programs/6/lessons/964/slide_shows\n"
+ "/shared/programs/6/lessons/944/slide_shows\n"
+ "/shared/programs/6/lessons/963/slide_shows\n"
+ "/shared/programs/6/lessons/970/slide_shows\n"
+ "/shared/sections/7352?nav_info=&program_id=15\n"
+ "/shared/sections/8991?program_id=15\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}