use strict;
my $str = 'Past Strings:
\\Dshared\\Dsections\\D\\d{3,5}[?]nav_info=&{0,1}program_id=6
Pass:
/shared/sections/6032?nav_info=&program_id=6
/shared/sections/6027?program_id=6
/shared/sections/8990?program_id=6
/shared/sections/6115?nav_info=&program_id=6
/shared/sections/7318?program_id=6
/shared/sections/8996?program_id=6
/shared/sections/6324?nav_info=&program_id=6
/shared/sections/6332?program_id=6
/shared/sections/6333?program_id=6
/shared/sections/6334?program_id=6
Fail:
/shared/programs/6/lessons/1126/slide_shows
/shared/programs/6/lessons/964/slide_shows
/shared/programs/6/lessons/944/slide_shows
/shared/programs/6/lessons/963/slide_shows
/shared/programs/6/lessons/970/slide_shows
/shared/sections/7352?nav_info=&program_id=15
/shared/sections/8991?program_id=15
';
my $regex = qr/\Dshared\Dsections\D\d{3,5}[?](program_id|nav_info=&program_id)=6/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}