$re = '/((low-|\d-|<-|<|->|>)\d*$)|other|low-high|(^\dhigh$)|^\d*$/mi';
$str = 'low-18
-20
19
20<-40
41-70
71-high
71-higher
low-71-high
lower-71
high-low
low-high
other
71-turn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);