const regex = new RegExp('((low-|\\d-|<-|<|->|>)\\d*$)|other|low-high|(^\\dhigh$)|^\\d*$', 'gmi')
const str = `low-18
-20
19
20<-40
41-70
71-high
71-higher
low-71-high
lower-71
high-low
low-high
other
71-turn`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}