#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)((low-|\d-|<-|<|->|>)\d*$)|other|low-high|(^\dhigh$)|^\d*$"
Local $sString = "low-18" & @CRLF & _
"-20" & @CRLF & _
"19" & @CRLF & _
"20<-40" & @CRLF & _
"41-70" & @CRLF & _
"71-high" & @CRLF & _
"71-higher" & @CRLF & _
"low-71-high" & @CRLF & _
"lower-71" & @CRLF & _
"high-low" & @CRLF & _
"low-high" & @CRLF & _
"other" & @CRLF & _
"71-turn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")