import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((low-|\\d-|<-|<|->|>)\\d*$)|other|low-high|(^\\dhigh$)|^\\d*$";
final String string = "low-18\n"
+ "-20\n"
+ "19\n"
+ "20<-40\n"
+ "41-70\n"
+ "71-high\n"
+ "71-higher\n"
+ "low-71-high\n"
+ "lower-71\n"
+ "high-low\n"
+ "low-high\n"
+ "other\n"
+ "71-turn";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}