import Foundation
let pattern = #"'((?:([^']*?)\\'[^']*?)*?)'|(?:\\')[^']*'([^']*)'|'([^']*?)'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
'test'
more'test'
'test'more
\'no'yes'
a 'one' and 'two' and 'three'...
nothing at all
''
''test
test''
te''st
'This is not wrong' and 'this isn\'t either'
'tw\'o repl\'acements' in 't\'wo stri\'ngs'.
'\\''
'''
'test1'\n'test2'
''''
[^\\]'([^']*)'|
{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy'PMOJwnmc2s\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\"2_f{BzP`.#v(yGtX\'O+4eU[P.3&1s+ xm!
PMOJwnmc2s
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)