use strict;
my $str = '\'test\'
more\'test\'
\'test\'more
\\\'no\'yes\'
a \'one\' and \'two\' and \'three\'...
nothing at all
\'\'
\'\'test
test\'\'
te\'\'st
\'This is not wrong\' and \'this isn\\\'t either\'
\'tw\\\'o repl\\\'acements\' in \'t\\\'wo stri\\\'ngs\'.
\'\\\\\'\'
\'\'\'
\'test1\'\\n\'test2\'
\'\'\'\'
[^\\\\]\'([^\']*)\'|
{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\\\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy\'PMOJwnmc2s\\\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\\"2_f{BzP`.#v(yGtX\\\'O+4eU[P.3&1s+ xm!
PMOJwnmc2s';
my $regex = qr/'((?:([^']*?)\\'[^']*?)*?)'|(?:\\')[^']*'([^']*)'|'([^']*?)'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}