// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'((?:([^']*?)\\'[^']*?)*?)'|(?:\\')[^']*'([^']*)'|'([^']*?)'").unwrap();
let string = "'test'
more'test'
'test'more
\\'no'yes'
a 'one' and 'two' and 'three'...
nothing at all
''
''test
test''
te''st
'This is not wrong' and 'this isn\\'t either'
'tw\\'o repl\\'acements' in 't\\'wo stri\\'ngs'.
'\\\\''
'''
'test1'\\n'test2'
''''
[^\\\\]'([^']*)'|
{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy'PMOJwnmc2s\\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\\\"2_f{BzP`.#v(yGtX\\'O+4eU[P.3&1s+ xm!
PMOJwnmc2s";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}