#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)'((?:([^']*?)\\'[^']*?)*?)'|(?:\\')[^']*'([^']*)'|'([^']*?)'"
Local $sString = "'test' " & @CRLF & _
"more'test' " & @CRLF & _
"'test'more " & @CRLF & _
"\'no'yes' " & @CRLF & _
"a 'one' and 'two' and 'three'... " & @CRLF & _
"nothing at all " & @CRLF & _
"'' " & @CRLF & _
"''test " & @CRLF & _
"test'' " & @CRLF & _
"te''st " & @CRLF & _
"'This is not wrong' and 'this isn\'t either' " & @CRLF & _
"'tw\'o repl\'acements' in 't\'wo stri\'ngs'. " & @CRLF & _
"'\\'' " & @CRLF & _
"''' " & @CRLF & _
"'test1'\n'test2' " & @CRLF & _
"'''' " & @CRLF & _
"" & @CRLF & _
"[^\\]'([^']*)'|" & @CRLF & _
"" & @CRLF & _
"{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy'PMOJwnmc2s\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\"2_f{BzP`.#v(yGtX\'O+4eU[P.3&1s+ xm!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"PMOJwnmc2s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")