$re = '/^\d{5}(\-?)\d{4}/m';
$str = '123456789';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;