use strict;
my $str = '123456789';
my $regex = qr/^\d{5}(\-?)\d{4}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";