const regex = /^\d{5}(\-?)\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{5}(\\-?)\\d{4}', 'gm')
const str = `123456789`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);