re = /(\<li\>(?:\n)*(?:.*)(?:\n)*\<\/li\>)/m
str = 'preceding text
<li>this is an item</li>
<li>this is another item</li>
following text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end