import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\<li\\>(?:\\n)*(?:.*)(?:\\n)*\\<\\/li\\>)";
final String string = "preceding text\n"
+ "<li>this is an item</li>\n"
+ "<li>this is another item</li>\n"
+ "following text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}