package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\<li\>(?:\n)*(?:.*)(?:\n)*\<\/li\>)`)
var str = `preceding text
<li>this is an item</li>
<li>this is another item</li>
following text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}