$re = '/(\<li\>(?:\n)*(?:.*)(?:\n)*\<\/li\>)/m';
$str = 'preceding text
<li>this is an item</li>
<li>this is another item</li>
following text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);