$re = '/http[s]?:\/\/\w+.*?\/([\w\d-_]+)\/(.*)/';
$str = 'https://github.intuit.com/DEVGRU-kathi/kathiravan/scorecard
http://github.intuit.com/DEVGRU/kathiravan/scorecard';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);