package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http[s]?:\/\/\w+.*?\/([\w\d-_]+)\/(.*)`)
var str = `https://github.intuit.com/DEVGRU-kathi/kathiravan/scorecard
http://github.intuit.com/DEVGRU/kathiravan/scorecard`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}