const regex = /http[s]?:\/\/\w+.*?\/([\w\d-_]+)\/(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http[s]?:\\\/\\\/\\w+.*?\\\/([\\w\\d-_]+)\\\/(.*)', 'g')
const str = `https://github.intuit.com/DEVGRU-kathi/kathiravan/scorecard
http://github.intuit.com/DEVGRU/kathiravan/scorecard`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}