import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http[s]?:\\/\\/\\w+.*?\\/([\\w\\d-_]+)\\/(.*)";
final String string = "https://github.intuit.com/DEVGRU-kathi/kathiravan/scorecard\n"
+ "http://github.intuit.com/DEVGRU/kathiravan/scorecard";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}