// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+?\d{0,2})?\s?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$").unwrap();
let string = "1
12
123
1234
12345
123456
1234567
12345678
123456789
1234567890
+1234567890
+123-456-7890
+123 456 7890
123 456 7890
123-456-7890
123 456-7890
123-456 7890
123-4567890
123456-7890
(234) 567 8940
(234)-567-8490
(425)512-7497
+919560862817
9560862817
956 086 2817
sgsdfgsd sdgsd sdg
asdf
+448897687877
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}