#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+?\d{0,2})?\s?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"1234" & @CRLF & _
"12345" & @CRLF & _
"123456" & @CRLF & _
"1234567" & @CRLF & _
"12345678" & @CRLF & _
"123456789" & @CRLF & _
"1234567890" & @CRLF & _
"+1234567890" & @CRLF & _
"+123-456-7890" & @CRLF & _
"+123 456 7890" & @CRLF & _
"123 456 7890" & @CRLF & _
"123-456-7890" & @CRLF & _
"123 456-7890" & @CRLF & _
"123-456 7890" & @CRLF & _
"123-4567890" & @CRLF & _
"123456-7890" & @CRLF & _
"(234) 567 8940" & @CRLF & _
"(234)-567-8490" & @CRLF & _
"(425)512-7497" & @CRLF & _
"+919560862817" & @CRLF & _
"9560862817" & @CRLF & _
"956 086 2817" & @CRLF & _
"sgsdfgsd sdgsd sdg " & @CRLF & _
"asdf" & @CRLF & _
"+448897687877" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")