import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+?\\d{0,2})?\\s?[\\D]?\\(?(\\d{3})\\)?[\\D]?(\\d{3})[\\D]?(\\d{4})$";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "1234\n"
+ "12345\n"
+ "123456\n"
+ "1234567\n"
+ "12345678\n"
+ "123456789\n"
+ "1234567890\n"
+ "+1234567890\n"
+ "+123-456-7890\n"
+ "+123 456 7890\n"
+ "123 456 7890\n"
+ "123-456-7890\n"
+ "123 456-7890\n"
+ "123-456 7890\n"
+ "123-4567890\n"
+ "123456-7890\n"
+ "(234) 567 8940\n"
+ "(234)-567-8490\n"
+ "(425)512-7497\n"
+ "+919560862817\n"
+ "9560862817\n"
+ "956 086 2817\n"
+ "sgsdfgsd sdgsd sdg \n"
+ "asdf\n"
+ "+448897687877\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}