re = /head-(?'BRAND'Бренд)?+(?'middle'(?:(?!Артикул|tail).)*+)(?'CODE'Артикул)?+(?'middle2'(?:(?!tail).)*+)tail/
str = 'head-Бренд-middle-Артикул-middle2-tail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end