using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"head-(?'BRAND'Бренд)?+(?'middle'(?:(?!Артикул|tail).)*+)(?'CODE'Артикул)?+(?'middle2'(?:(?!tail).)*+)tail";
string input = @"head-Бренд-middle-Артикул-middle2-tail";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}