$re = '/head-(?\'BRAND\'Бренд)?+(?\'middle\'(?:(?!Артикул|tail).)*+)(?\'CODE\'Артикул)?+(?\'middle2\'(?:(?!tail).)*+)tail/U';
$str = 'head-Бренд-middle-Артикул-middle2-tail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);