const regex = /head-(?'BRAND'Бренд)?+(?'middle'(?:(?!Артикул|tail).)*+)(?'CODE'Артикул)?+(?'middle2'(?:(?!tail).)*+)tail/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('head-(?\'BRAND\'Бренд)?+(?\'middle\'(?:(?!Артикул|tail).)*+)(?\'CODE\'Артикул)?+(?\'middle2\'(?:(?!tail).)*+)tail', 'g')
const str = `head-Бренд-middle-Артикул-middle2-tail`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}