import Foundation
let pattern = #"^([\w\.]+)\s*\d[\d\.\-]*\w*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3rosCore 2.0.9
3rosCore 2.0.9-rc
3rosCore 2.0.8
3rosCore 2.0.8-rc
3rosCore 2.0.7
3rosCore 2.0.6
3rosCore 2.0.5
3rosCore 2.0.5-rc
3rosCore 2.0.4-rc
3rosCore 1.0.7
3rosCore 1.0.6
3rosCore 1.0.5
3rosCore 1.0.4
3rosCore 1.0.3
3rosCore 1.0.2
3rosCore 1.0.1
3rosWeb 2.0.0-rc
3rosWeb 1.0.2-rc
3rosWeb 1.0.1
3rosWeb 1.0.0
3rosWebApi 2.0.0
3rosWebApi 1.0.0
Actsis.ECharts.Standard 8.0.1695-beta
Actsis.ECharts.Standard 8.0.1691-beta
Actsis.ECharts.Standard 8.0.1689-beta
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)