use strict;
my $str = '3rosCore 2.0.9
3rosCore 2.0.9-rc
3rosCore 2.0.8
3rosCore 2.0.8-rc
3rosCore 2.0.7
3rosCore 2.0.6
3rosCore 2.0.5
3rosCore 2.0.5-rc
3rosCore 2.0.4-rc
3rosCore 1.0.7
3rosCore 1.0.6
3rosCore 1.0.5
3rosCore 1.0.4
3rosCore 1.0.3
3rosCore 1.0.2
3rosCore 1.0.1
3rosWeb 2.0.0-rc
3rosWeb 1.0.2-rc
3rosWeb 1.0.1
3rosWeb 1.0.0
3rosWebApi 2.0.0
3rosWebApi 1.0.0
Actsis.ECharts.Standard 8.0.1695-beta
Actsis.ECharts.Standard 8.0.1691-beta
Actsis.ECharts.Standard 8.0.1689-beta';
my $regex = qr/^([\w\.]+)\s*\d[\d\.\-]*\w*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}