package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w\.]+)\s*\d[\d\.\-]*\w*`)
var str = `3rosCore 2.0.9
3rosCore 2.0.9-rc
3rosCore 2.0.8
3rosCore 2.0.8-rc
3rosCore 2.0.7
3rosCore 2.0.6
3rosCore 2.0.5
3rosCore 2.0.5-rc
3rosCore 2.0.4-rc
3rosCore 1.0.7
3rosCore 1.0.6
3rosCore 1.0.5
3rosCore 1.0.4
3rosCore 1.0.3
3rosCore 1.0.2
3rosCore 1.0.1
3rosWeb 2.0.0-rc
3rosWeb 1.0.2-rc
3rosWeb 1.0.1
3rosWeb 1.0.0
3rosWebApi 2.0.0
3rosWebApi 1.0.0
Actsis.ECharts.Standard 8.0.1695-beta
Actsis.ECharts.Standard 8.0.1691-beta
Actsis.ECharts.Standard 8.0.1689-beta`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}