using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w\.]+)\s*\d[\d\.\-]*\w*";
string input = @"3rosCore 2.0.9
3rosCore 2.0.9-rc
3rosCore 2.0.8
3rosCore 2.0.8-rc
3rosCore 2.0.7
3rosCore 2.0.6
3rosCore 2.0.5
3rosCore 2.0.5-rc
3rosCore 2.0.4-rc
3rosCore 1.0.7
3rosCore 1.0.6
3rosCore 1.0.5
3rosCore 1.0.4
3rosCore 1.0.3
3rosCore 1.0.2
3rosCore 1.0.1
3rosWeb 2.0.0-rc
3rosWeb 1.0.2-rc
3rosWeb 1.0.1
3rosWeb 1.0.0
3rosWebApi 2.0.0
3rosWebApi 1.0.0
Actsis.ECharts.Standard 8.0.1695-beta
Actsis.ECharts.Standard 8.0.1691-beta
Actsis.ECharts.Standard 8.0.1689-beta";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}