// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d").unwrap();
let string = "Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\\\"1234567890123456\\\" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa";
let substitution = "$1******$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}